Impact APP Slow performance

Incident Report for SteadyIQ

Resolved

This incident has been resolved.
Posted Oct 30, 2024 - 19:00 UTC

Monitoring

A fix has been implemented, and we are currently monitoring the situation.
Posted Oct 30, 2024 - 18:01 UTC

Investigating

We're experiencing performance issues with the Impact App, causing certain features to operate below expected speed and responsiveness.

Our team is actively investigating the root cause and working on a resolution. We apologize for any inconvenience this may cause and appreciate your patience as we restore optimal performance.

Thank you for being so understanding.

Best regards,
The Steady Team
Posted Oct 30, 2024 - 17:58 UTC
This incident affected: Backend Systems.