AWS service disruptions

Incident Report for SteadyIQ

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 02:40 UTC

Monitoring

Monitoring: The AWS outage has been resolved. All systems are now fully operational, and services are functioning normally. We are continuing to monitor for any further issues.
Posted Oct 21, 2025 - 02:17 UTC

Update

We are continuing to investigate this issue.
Posted Oct 20, 2025 - 18:48 UTC

Update

We are continuing to investigate this issue.
Posted Oct 20, 2025 - 18:46 UTC

Investigating

We are currently experiencing service disruptions due to an issue with one of our infrastructure partners, AWS. It affects certain aspects of our platform's performance and availability.

Our team is actively monitoring the situation and will provide updates as soon as more information becomes available.
Posted Oct 20, 2025 - 15:43 UTC
This incident affected: Main Service (SteadyIQ) and Backend Systems.